PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Collatz GPU-berechnung



GER_J0k3r
08.07.2010, 16:07
Heyho,

ich bin nebenj MW auch CC am crunchen (normale Anwendung von BOINC geladen).

Ich habe bei meinem CC Account nur GPU-Anwendungen zugelassen.

Da steht nun 0,05CPU + 1,0 ATI. Laut Overdrive habe ich 96% GraKaauslastung bei 40°C.

Aber der CPU gammelt mit nimma 10% Auslastung vor sich hin. Würde das was bringen den hochzustellen, damit die GPU mehr unterstützt wird? Ausserdem wird nur eine WU von CC gerechnet. Wie bekomme ich das hin, dass mehrere gerechnet werden? Bringt das was überhaupt?!

Wie stelle ich CC so ein, dass es am meisten Credits bekommt, und dass der PC maximal ausgelastet ist?

http://www.sysprofile.de/id85914 <- Mein Sys

mfg und Danke vorab

AgentSchatten
08.07.2010, 21:48
Bei CC brauchst du eigentlich nichts weiter optimieren. Ist schon recht gut optimiert. Für die CPU würde ich mir einfach ein anderes Projekt aussuchen. Cr optimieren wäre momentan eigentlich Milkyway auf GPU und Aqua auf CPU. Meiner Meinung nach.

gu_wo
11.01.2011, 09:49
Hi,

wollte keinen neuen Thread mit der gleichen Überschrift aufmachen, daher klinke ich mich mal hier ein.

Habe eine Frage:

Hat sich bei den Berechnungen was geändert?

Hatte zuvor immer 0,01CPUs + 1,0 NVIDIA GPUs

seit gestern steht da 0,55CPUs + 1,0 NVIDIA GPUs und die einzelnen WU´s sind von fast 1h auf 3h sogar 12h verbleibende Zeit angestiegen, es befinden sich auch nicht mehr so viele WU´s im Bunker.

In den Einstellungen habe ich aber nichts verändert.

Könnt ihr mir da weiterhelfen?


EDIT:

.... muss ich jetzt nicht verstehen, gerade als ich das hier geschrieben hatte, hatte sich das wohl irgendwie aktualisiert.
0,01CPUs + 1,0 NVIDIA GPUs !!! Nur die WU´s sind noch so geblieben, vielleicht ändert sich das auch bei den Nächsten?

pschoefer
11.01.2011, 10:01
Hat sich bei den Berechnungen was geändert?

Hatte zuvor immer 0,05CPUs + 1,0 NVIDIA GPUs

seit gestern steht da 0,55CPUs + 1,0 NVIDIA GPUs und die einzelnen WU´s sind von fast 1h auf 3h sogar 12h verbleibende Zeit angestiegen, es befinden sich auch nicht mehr so viele WU´s im Bunker.
Die Länge der WUs wurde vervierfacht, vor allem, um den Server zu entlasten.

Dass der Wert, wieviel CPU benötigt wird, ebenfalls gestiegen ist, war ein unbeabsichtigter Nebeneffekt (ein nettes Feature des BOINC-Servers). Mit der tatsächlichen CPU-Nutzung hat das allerdings nichts zu tun. Es würde nur zu Problemen führen, wenn du jetzt zwei GPUs hättest, weil dann eine komplette CPU unnötigerweise freigehalten würde.

gu_wo
11.01.2011, 10:17
Hi,

ach so ist das.

OK und danke für die Info! :thumbup:

taurec
12.01.2011, 19:04
;179545']
Dass der Wert, wieviel CPU benötigt wird, ebenfalls gestiegen ist, war ein unbeabsichtigter Nebeneffekt (ein nettes Feature des BOINC-Servers). Mit der tatsächlichen CPU-Nutzung hat das allerdings nichts zu tun. Es würde nur zu Problemen führen, wenn du jetzt zwei GPUs hättest, weil dann eine komplette CPU unnötigerweise freigehalten würde.

@pschoefer,
da ich seit kurzem in Besitz einer GTX295 bin, kann ich irgendwie verhindern, dass eine komplette CPU belegt wird?
Sorry, habe bisher keine Erfahrung mit GPU-Crunching ;)

pschoefer
12.01.2011, 19:38
@pschoefer,
da ich seit kurzem in Besitz einer GTX295 bin, kann ich irgendwie verhindern, dass eine komplette CPU belegt wird?
Sorry, habe bisher keine Erfahrung mit GPU-Crunching ;)
Eigentlich sollte den GPU-WUs (egal ob ATI oder NVIDIA) inzwischen wieder generell mitgegeben werden, dass sie 0,01 CPUs belegen. Also dürfte das Problem bei frischen WUs inzwischen nicht mehr auftreten. ;)

Ansonsten gibt es die Möglichkeit, diesen Wert mit einer app_info.xml zu überschreiben. Da habe ich aber gerade keine zur Hand.

gu_wo
14.01.2011, 21:23
muß das nicht erst in den jeweiligen Einstellungen im Projekt (Ihr Konto) geändert werden, das nur dafür die GPU arbeiten soll, war zumindest bei mir damals so als ich mit dem GPU crunching angefangen hatte.

Einstellungen für dieses Projekt:
-Benutzung CPU - nein
-Benutzung NVIDIA/ATI GPU - ja

Einstellungen für Boinc/PC:
-Ausführung anhalten wenn der Computer benutzt wird? ja
-Ausführung auf Grafikkarte anhalten wenn der Computer benutzt wird? nein

... so sollte ich das damals einstellen, dann alles aktualisieren und der Rest geht von selbst.


Hinzugefügter Post:


;179646']Eigentlich sollte den GPU-WUs (egal ob ATI oder NVIDIA) inzwischen wieder generell mitgegeben werden, dass sie 0,01 CPUs belegen. Also dürfte das Problem bei frischen WUs inzwischen nicht mehr auftreten. ;)



jepp, läuft wieder alles normal!

gu_wo
29.04.2011, 21:16
Hallo,

ich hatte nach eine kleinen Pause, in der ich mir auch einen neuen PC zugelegt hatte, meinen Boinc mit 2 Tage Bunker gefüttert, nebenbei natürlich auch meine anderen Projekte.
Jetzt sind soweit alle WUs aufgebraucht und auch fertig, doch es wird nix abgeholt und ich bekomme auch keine neuen WUs.
Erst wenn ich selber alles aktualisiere läufts weiter, nur bei Collatz nicht.
Hatte bereits mein Problem woanders hier gepostet, bis auf "ich sollte mich gedulden", was ich auch tat, kam leider nix mehr.

Das scheint doch eher ein Problem zu sein, weniger eine Geduldsfrage!

Liegt es am Bionc, an irgendwelchen Einstellungen oder an den Projekten?

Habe gerade den Bunker auf 5 Tage gestellt und nur erstmal Milky dazu genommen, 4 Collatz WUs müßen noch berechnet werden, dann wäre auch da Feierabend, komisch ist jetzt habe ich wieder WUs erhalten.... :undecided:

Ich verstehe es nicht!

Könnt ihr mir weiterhelfen?

SoEinWahnsinn
29.04.2011, 22:48
als Notfall "Workaround" würde ich mir erst mal eine cc_config.xml , mit dem Inhalt
<cc_config>
<options>
<report_results_immediately>1</report_results_immediately>
</options>
<log_flags>
</log_flags>
</cc_config> anlegen. Sollte im Wiki zu finden sein...

Im BOINC mgr unter Einstellungen " Verbinde alle XYZ Tage" was steht da bei dir?

gu_wo
30.04.2011, 01:26
Hallo,

danke für die schnelle Antwort.;)

Also zu ersten Teil, leider habe ich so etwas noch nicht gemacht, müsste mich diesbezüglich erst mal schlau machen, was das ist und wozu ich das benötige.

Dann zum zweiten Teil, bei mir steht da: "verbinde etwa alle 0,10 Tage"
Daran hatte ich noch nie etwas geändert, funktionierte vor meinem PC Neu-Kauf einwandfrei.

Hatte zuvor ein PC Problem, daher hatte ich Boinc deinstalliert, jetzt wo alles neu ist, brauchte ich Boinc nur wieder installieren, alle Einstellungen waren ja noch vorhanden.

THX

SoEinWahnsinn
30.04.2011, 10:39
Setze da mal bei dem Reiter "Nutzung des Netzwerks" alles auf "0" und entferne alle Haken. Nur beim "Zusätzlichen Arbeitspuffer" sollte ein Wert von einigen Tagen stehen.

Wie du eine cc_config.xml anlegst ist hier (http://www.seti-germany.de/wiki/Cc_config.xml) beschrieben. Wichtig sind nur die ersten paar Zeilen für dich. Also nicht vom Rest dich ablenken lassen, den Inhalt hab ich dir ja oben schon vorgegeben.
Ist aber wie gesagt nur Flickwerk, eine dauerhafte Lösung sollte das nicht sein.
Zum ausschalten des Parameters brauchst du nur die Datei Löschen, oder du machst bei "<report_results_immediately>1</report_results_immediately>" statt der 1 eine 0 rein. Anschließend den BoincMgr neu starten oder unter "Extras" ---> "Konfigurationdatei lesen"

gu_wo
30.04.2011, 12:36
Setze da mal bei dem Reiter "Nutzung des Netzwerks" alles auf "0" und entferne alle Haken. Nur beim "Zusätzlichen Arbeitspuffer" sollte ein Wert von einigen Tagen stehen.
Hallo,
- es waren bereits alle Haken raus
- alle Werte bis auf:
verbinde etwa alle Tage : 0,10
Arbeitspuffer: 5
waren schon auf 0 gestellt.

habe jetzt wie du empfohlen hattest alles auf 0 gesetzt und weil zu viel im Bunker war erst mal wieder auf 1 Tag gestellt.
Hoffe das geht so i.O.?



Wie du eine cc_config.xml anlegst ist hier (http://www.seti-germany.de/wiki/Cc_config.xml) beschrieben. Wichtig sind nur die ersten paar Zeilen für dich. Also nicht vom Rest dich ablenken lassen, den Inhalt hab ich dir ja oben schon vorgegeben.
Ist aber wie gesagt nur Flickwerk, eine dauerhafte Lösung sollte das nicht sein.
Zum ausschalten des Parameters brauchst du nur die Datei Löschen, oder du machst bei "<report_results_immediately>1</report_results_immediately>" statt der 1 eine 0 rein. Anschließend den BoincMgr neu starten oder unter "Extras" ---> "Konfigurationdatei lesen"

sorry, muß mich erstmal damit genauer beschäftigen, auch wenns gut erklärt sein sollte, hatte damit noch nie etwas gemacht und da es ja auch keine Dauerlösung ist, weiß ich auch nicht ob das Sinn macht.:redface:
Aber ich werde das demnächst trotzdem mal testen. ;)

THX

SoEinWahnsinn
30.04.2011, 13:47
Seltsam... Lass das mal vorläufig so.
Wie sieht bei dir die Ressourcenaufteilung der Projekt im BoincMgr aus?

gu_wo
30.04.2011, 15:39
Hi,
da ich hauptsächlich mit Collatz arbeite, ist dies auf 100% alle anderen auf 2%.

oder sollte ich alle Projekte auf 100% stellen?


habe gerade mal alle auf 100% eingestellt.... schaun wa mal ;-)

SoEinWahnsinn
30.04.2011, 22:02
Passt schon...

Dass letzte was mir noch auf Anhieb einfällt wäre, die "debts" zu "reseten". Da das über Kommandozeile auch recht tricky ist, einfach mal Collatz auf "keine neue Arbeit stellen" leer rechnen lassen alle Aufgaben zurück melden. DANACH erst das Projekt abmelden Boinc beenden, (manuell nochmal kontrollieren ob Collatz vom Rechner komplett verschwunden ist..) Windows neu starten, und das Projekt wieder anmelden...

Falls das nicht hilft, weiß ich auch nicht mehr weiter. Dann kannst du dir m.M.n. nur noch mit der cc_config oder einem update Script helfen...

Edit:
Besser noch Boinc komplett neu installieren...
Falls bei anderen Projekten was mit den Debts außer Ruder gelaufen sein sollte. Bitte da eventuelle Reste der ZWEI Boinc Ordner nach dem deinstallieren noch manuell kontrollieren/entfernen.
Bei Win 7 z.Bsp. unter "C:\Programm Files" & "C:\ProgrammData" (falls der vorgegebene Installationpfad benutzt wurde)

gu_wo
01.05.2011, 02:06
Hi,

THX für die Tipps, werde das erstmal so laufen und alles zu ende rechnen lassen.
Mal sehn was so alles passiert.
Dein "Edit" Vorschlag hört sich gut u. einfach an, (denn das mit den Kommandozeilen ist nicht meine Welt) werde das dann später so machen.

Melde mich wenns soweit ist!!! :thumbup:;)


Sorry...... "debts" was meinst du mit "Schulden"????? :redface:
Die noch zu berechnenden WUs?

SoEinWahnsinn
01.05.2011, 10:35
Boinc führt sagen wir mal eine Statistik, in der berechnet wird wieviel Arbeit von den Projekten angefordert werden sollte.
Da fließen deine Einstellungen wie Resourcenaufteilung, die Bunkereinstellung mit ein ebenso wie dein Nutzerverhalten (wie oft und wie lang läuft Boinc). Daraus errechnen sich dann die "Schulden" (short_term_debt / long_term_debt) und es wird Arbeit angefragt oder halt nicht.

Da fällt mir noch eine Alternative ein du könntest im Ordner C:\ProgramData\BOINC die Debts per Hand korrigieren. Also Boinc komplett beenden (notfalls per TaskMgr die letzten Instanzen killen) die client_state_prev.xml löschen und die client_state.xml mit einem Editor öffnen. (Schreibrechte ggf. noch überprüfen)

Ganz am Anfang die Werte mal auf 1.000000 setzen. (Wichtig das sind Punkte keine Kommata)

<time_stats>
<on_frac>0.824921</on_frac>
<connected_frac>0.999884</connected_frac>
<active_frac>0.999890</active_frac>
<last_update>1304237532.054739</last_update>
</time_stats>

Dann per Suche (Strg +F) von "term_debt>" sämmtliche Werte auf 0.000000 setzen. Für jedes Projekt das du angemeldet hast sollte ein solcher Block existieren.


<short_term_debt>-42.741575</short_term_debt>
<long_term_debt>0.000000</long_term_debt>
<cpu_backoff_interval>0.000000</cpu_backoff_interval>
<cpu_backoff_time>0.000000</cpu_backoff_time>
<cuda_short_term_debt>0.000000</cuda_short_term_debt>
<cuda_debt>0.000000</cuda_debt>
<cuda_backoff_interval>0.000000</cuda_backoff_interval>
<cuda_backoff_time>0.000000</cuda_backoff_time>
<ati_short_term_debt>0.000000</ati_short_term_debt>
<ati_debt>0.000000</ati_debt>
<ati_backoff_interval>86400.000000</ati_backoff_interval>
<ati_backoff_time>1304195762.962780</ati_backoff_time>
<resource_share>10.000000</resource_share>

Anschließend speichern und Boinc neu starten.:D

gu_wo
01.05.2011, 13:25
Hallo,

erstmal vielen Dank für deine Erkärung, das habe ich soweit verstanden.:)

Werde das evtl. heute noch machen.

Nur ne kliene INFO am Rande, da ich ja alles zu ende rechnen lassen wollte, hatte ich den PC wieder über Nacht an, gerade habe ich mich davor gesetzt und mußte feststellen, das er mittlerweile schon an einer WU von Collatz satte 17 h zugange ist und die verbleibende Zeit fast 7h und steigend ist.
Denke druch die ganzen Einstellungen von gestern, liegt doch bestimmt ein Berechnungsfehler vor, denn so mega lange hatte noch keine Collatz WU gedauert.
Mittlerweile sind auch 3 Milky WUs fertig und werden nicht abgeholt.

Was sollte ich denn jetzt ersrmal machen, bevor ich die nächsten Schritte einleite?

Wünsche einen schönen 1. Mai

THX

leprechaun
01.05.2011, 13:26
Boinc führt sagen wir mal eine Statistik, in der berechnet wird wieviel Arbeit von den Projekten angefordert werden sollte.
Da fließen deine Einstellungen wie Resourcenaufteilung, die Bunkereinstellung mit ein ebenso wie dein Nutzerverhalten (wie oft und wie lang läuft Boinc). Daraus errechnen sich dann die "Schulden" (short_term_debt / long_term_debt) und es wird Arbeit angefragt oder halt nicht.

Da fällt mir noch eine Alternative ein du könntest im Ordner C:\ProgramData\BOINC die Debts per Hand korrigieren. Also Boinc komplett beenden (notfalls per TaskMgr die letzten Instanzen killen) die client_state_prev.xml löschen und die client_state.xml mit einem Editor öffnen. (Schreibrechte ggf. noch überprüfen)

Ganz am Anfang die Werte mal auf 1.000000 setzen. (Wichtig das sind Punkte keine Kommata)


Dann per Suche (Strg +F) von "term_debt>" sämmtliche Werte auf 0.000000 setzen. Für jedes Projekt das du angemeldet hast sollte ein solcher Block existieren.



Anschließend speichern und Boinc neu starten.:D

Viel komfortabler geht das mit einen Tool namens BoincDev. Das kann auch so eingebunden werden, das, wenn Boinc startet, alle Werte von short und long_term auf Null gesetzt werden.
Auch eine Rücksetzung im laufenden Betrieb ist möglich. Hinterher nur die lokale Config im Boincmanager neu einlesen lassen. Boinc Hauptordner sichtbar machen vorher, denn es wird der Ort gebraucht, wo die client_state.xml lagert.

gu_wo
01.05.2011, 13:57
Hi nochmal,

da es mir keine Ruhe gibt habe ich gerade damit angefangen.
- Bionc beendet
- dein 1. Zitat, 1.000000 habe ich ersetzt
- dein 2. Zitat, die Suche findet term_debt> nicht?

und nun?


Hinzugefügter Post:

Hallo,

finde dieses Prog. namens BoincDev nicht.

SoEinWahnsinn
01.05.2011, 14:07
Nicht die Windows Suche verwenden, im Editor die Tasten "Strg" & "F" gleichzeitig betätigen, dann erscheint ein "Suchen Fenster" in das kopierst du den Suchbegriff "term_debt>" wählst die Suchrichtung aus und klickst auf Suchen/Weitersuchen.

Das Programm hatte ich total vergessen, war immer so umständlich für mich :)

Das die Collatz Wu so lange braucht liegt wohl an was anderem, mal im TaskMgr nachgeschaut ob sie noch lief?

gu_wo
02.05.2011, 20:48
Hallo ihr beiden,

also, habe gerade kurzen Prozess gemacht, Bionc deinstalliert und alle Ordner gesucht u. gelöscht.

Jetzt gerade alles neu installiert.

Erstmal nur Collatz u. Milky angemeldet.

Einstellungen:
Collatz 100%
Milky 2%

Nutzung des Prozessors:
alle 3 Haken gemacht und unten 60 min., 50% (da ich nur 3 von 6 Kernen benutzen wollte), und 100%

Nutzung des Netzwerks:
alles auf 0 und den Bunker auf 0,25 Tage, damit es jetzt erstmal nicht zu viele sind, da keine Haken gesetzt.


Werde das jetzt erstmal so laufen lassen.


Interessant was jetzt da so läuft.
Collatz ist ok, da das ja die GPU macht.
Milky läuft jetzt aber anders.
Vorher wurden immer 3 WUs gleichzeitig berechnet, weil ich 3 Kerne eingestellt hatte.
Jetzt wird nur eine WU berechnet, aber 3x so schnell, da steht jetzt "Aktiv (3.0 CPUs)"

und siehe da, die erste Milky WU die gerade feritg war, wurde bereits schon abgeholt.:thumbup:


Also das scheint wohl zu funzen........ hoffe ich, das das auch so bleibt.


Hinzugefügter Post:

So, ein keines Update, schaue hin u. wieder mal ins Bionc

hat sich schon wieder was geändert.
Milky läuft wieder wie zuvor, also mit 3 WUs die gleichzeitig berechnet werden.
Lag wohl an den WUs, die nannten sich Milkyway@Home N-Boby Simulation 0.4 (mt)

und Collatz brauch noch ne weile bis der erste fertig ist. :D


Hinzugefügter Post:

naja, mittlerweile häufen sich schon wieder die fertigen WUs. :undecided:

mache morgen damit weiter. :D


Hinzugefügter Post:

..... die WUs werden auch mittlerweile abgeholt, geht doch..... :D


Habe nur so mal ne Frage:
was genau bedeutet die Einstellung im Boinc Manager:
"Wenn die CPU-Auslastung geringer als ... % (0= keine Einschränkung)"

Stand zuvor auf 25% bei der Neuinstallation, mir wurde empfohlen die ja auf 0% einstellen.

und "Nutze höchstens 100% Prozessor-Zeit"

ist das nicht das selbe????

THX

SoEinWahnsinn
02.05.2011, 21:17
Bei der ersten Einstellung wird Boinc angehalten sobald ein anderer Prozess mehr als 25% deines Prozessors in Anspruch nimmt. Sinnvoll z.Bsp. bei Produktiv Systemen geringer Leistung...

Bei der zweiten kannst du einstellen wie viel dein Prozessor sich nehmen darf... (der Rest bleibt im Leerlauf oder für andere Prozesse)
Aber gerade die Variante ist sehr ungünstig zum steuern. Da die CPU trotz alledem auf vollem Takt gehalten wird und nur Schubweise Last erhält. Ist nur mal im Fehlerfall sinnvoll (Temperaturprobleme etc.), falls du damit Strom sparen willst, dann schalte den Rechner lieber ab ;)

gu_wo
03.05.2011, 18:24
Hallo,

danke, alles klar. :thumbup:

Dann lasse ich es bei 1) 0% und 2) 100%.

PS: heute die Info erhalten das endlich meine GTX570 versendet wurde. Bin mal gespannt was dann die Collatz WUs dazu sagen. :D


Hinzugefügter Post:

.... wenn mann vom Teufel spricht ;)
Graka ist da, ging ja fix. :D

So meine Lieben, da es doch jetzt eine GTX570 ist, dachte ich mir, die Collatz WUs werden schneller abgefertigt, wieso eigentlich nicht?

Die GTX mit neusten Treibern und wird überall erkannt! Das müsste doch jetzt regelrecht im PC burnen aber nix da, alles wie zuvor, natürlich nur im Zusammenhang mit den WUs :sad:

SoEinWahnsinn
03.05.2011, 19:05
Die Karte ist bei Primegrid deutlich besser aufgehoben. Bei Collatz ist ATI/AMD eindeutiger Sieger.

phaeton57
03.05.2011, 20:03
Die Karte ist bei Primegrid deutlich besser aufgehoben. Bei Collatz ist ATI/AMD eindeutiger Sieger.

:zustimm:

Gruss phaeton57:x)

gu_wo
04.05.2011, 08:28
mußte sich wohl alles erstmal einpegeln, mittlerweile werden die WUs alle 35min. fertiggestellt und auch abgeholt.
Wenn es so bleibt, dann bin ich zufrieden.
schön-schön! :D :thumbup:

War wohl in den letzten Tagen etwas ungeduldig.:rolleyes:

:x)


Hinzugefügter Post:


Die Karte ist bei Primegrid deutlich besser aufgehoben. Bei Collatz ist ATI/AMD eindeutiger Sieger.

:redface: habe ich doch glatt gerade übersehen!

THX für den Tipp

Primegrid .... für meine Graka optimal, werde mich in Kürze damit mal näher beschäftigen. :thumbup:


Hinzugefügter Post:

kann ich denn Primegrid einfach dazu nehmen, so das sich Collatz und Primegrid die graka teilen?


Hinzugefügter Post:

habe mich da gerade angemeldet,
Boinc sagt mir:
04.05.2011 00:48:57 PrimeGrid Message from server: No work available for the applications you have selected. Please check your project preferences on the web site.


habe da mal geschaut, da gibt es nur 2 Projekte für die GPU oder wie muß ich das verstehen, bin jetzt beim "Cullen/Woodall Prime Search (Sieve)"
gerade bekam ich die ersten WUs, sind zum Arbeiten bereit, lasse den PC jetzt mal laufen.

Bin schon eh viel zu spät dran, muß bubu machen, mal morgen früh schaun. :x)


Hinzugefügter Post:

guten Morgen,

Primegrid läuft u. läuft, wird alles schön berechnet und abgeholt, das geht ja richtig zur Sache :D, doch wenn Collatz an der Reihe war gab es einige Berechnungsfehler. :undecided:

Primegrid bremst mein System etwas aus, gerade beim surfen ist mir das aufgefallen.

So jetzt muß ich los.


Könnt ihr mir da nochmal weiterhelfen. THX

HeNiNnG
04.05.2011, 09:05
Hinzugefügter Post:
[/COLOR][/B]
kann ich denn Primegrid einfach dazu nehmen, so das sich Collatz und Primegrid die graka teilen?



Hinzugefügter Post:

guten Morgen,

Primegrid läuft u. läuft, wird alles schön berechnet und abgeholt, das geht ja richtig zur Sache :D, doch wenn Collatz an der Reihe ist macht der nur Berechnungsfehler. :undecided:

Primegrid bremst mein System etwas aus, gerade beim surfen ist mir das aufgefallen.

So jetzt muß ich los.


Könnt ihr mir da nochmal weiterhelfen. THX

Also zu punkt eins: Dass Das funktioniert (bis auf die berechnungsfehler, die aber mit PG nichts zu tun haben) hast du ja schon herausgefunden...

Zu punkt 2: ja, PG bringt die Grafikkarte ganz schön ins schwitzen...wenn es dir beim surfen, etc. zu ruckelig wird kannst du entweder komplett die Berechnung auf der GPU stoppen (rechtsklick auf Das boinc Icon rechts unten und dann 'gpu pausieren' oder du pausierst nur PG...dann kann collatz weitermachen (das machst du am besten indem du im boinc Manager primegrid auswählt und dann auf 'anhalten' klickst...:)
Ich hoffe ich konnte helfen xD

Zu den berechnungsfehlern bei collatz kann ich leider nich nichts sagen...


Via Tapatalk von meinem HTC Incredible S gepostet.

gu_wo
04.05.2011, 09:30
Hallo,

erstmal danke für die schnelle Hilfe, alles klar, wenns mir zuviel wird dann halte ich PG einfach an, OK! ;)

Ach und mir ist auch noch eben aufgefallen, das im Boinc Manager beim Status stand
PG ------> Aktiv (0,33 CPU+1 NVIDIA GPUs)

läuft bei PG die CPU auch etwas mit oder ist das so normal?
Muß ich bei PG etwas anderes einstellen?

sobald wieder Collatz läuft steht da wieder Aktiv (0,1 CPU+1 NVIDIA GPUs)

HeNiNnG
04.05.2011, 10:07
Ach und mir ist auch noch eben aufgefallen, das im Boinc Manager beim Status stand
PG ------> Aktiv (0,33 CPU+1 NVIDIA GPUs)

läuft bei PG die CPU auch etwas mit oder ist das so normal?
Muß ich bei PG etwas anderes einstellen?

sobald wieder Collatz läuft steht da wieder Aktiv (0,1 CPU+1 NVIDIA GPUs)

ja...so ist es ;)
alle GPU-projekte nutzen auch ein wenig CPU-Zeit...wieviel ist von Projekt zu Projekt unterschiedlich...und PG nutzt offensichtlich ein wenig mehr CPU, als Colltatz...

Das ruckeln, das du bei PG feststellst kommt allerdings nicht daher...das liegt daran, dass PG due GraKa effizienter nutzt (sprich 99% Auslastung) - kannst du glaub ich mit GPU-Z auslesen...

pschoefer
04.05.2011, 10:28
Die Werte zur CPU-Nutzung, die im BOINC-Manager angezeigt werden, entsprechen allerdings nicht unbedingt der Wirklichkeit. In der Realität sind sowohl Collatz Conjecture als auch PrimeGrid äußerst sparsam, eher Richtung 0,05 CPUs. ;)

gu_wo
04.05.2011, 12:40
Hallo ihr beiden, :x)

danke für die Info, soweit ist alles klar. THX :thumbup:

Trotzdem habe ich noch das Problem mit den Berechnungsfehlern.

Hatte mal in die Collatz-Liste geschaut:
Bekomme immer 2 verschiedene WUs
- collatz v2.03 (cuda23)
- mini collatz v2.05 (cuda31)

jedenfalls sind bei allen mini collatz die Berechnungsfehler seitdem ich PG laufen lasse.
d.H. mittlerweile sind da fast 20 Fehler beim Berechnen
und allerdings auch 6 bei den collatz v2.03 (wobei davon hin u. wieder einer berechnet und versendet wird)

Kann es sein, das Collatz und PG nicht gut zusammenarbeiten, ich meine das sollen sie doch auch nicht, sie wechseln sich doch ab, daher verstehe ich diese Probleme nicht.

Vielleicht liegt es doch an irgendwelchen Einstellungen?

Uwe-Bergstedt
04.05.2011, 12:42
nur SETI ist da sehr gefräßig da wird 0,73 plus 1GPU angezeigt,meine GTX 295(2Kerne)schnappt sich da glatt einen kompletten CPU-Kern sodas von einem Quad nur noch 3Kerne für ein anderes Projekt zur Verfügung stehen,bei meinen DualCore bleibt nur 1Kern übrig:sad:

phaeton57
04.05.2011, 12:48
Hinzugefügter Post:
[/COLOR][/B]
guten Morgen,

Primegrid läuft u. läuft, wird alles schön berechnet und abgeholt, das geht ja richtig zur Sache :D, doch wenn Collatz an der Reihe war gab es einige Berechnungsfehler. :undecided:

Primegrid bremst mein System etwas aus, gerade beim surfen ist mir das aufgefallen.

So jetzt muß ich los.


Könnt ihr mir da nochmal weiterhelfen. THX

Versuch mal PPS sieve auf CUDA zurechnen, da hast Du noch höhere "Erträge" als bei Cullen/Woodall


Gruss phaeton57:x)

gu_wo
04.05.2011, 13:02
Versuch mal PPS sieve auf CUDA zurechnen, da hast Du noch höhere "Erträge" als bei Cullen Wullen.


Gruss phaeton57:x)


Hi,

kann ich denn dann beiden PG-Projekte laufen lassen?

Möchte jetzt nicht zu viel durcheinander machen, bevor das mit dem Collatz-Berechnungsfehler geklärt ist.

phaeton57
04.05.2011, 14:08
Ja, kann man, ist alles kein Problem. Mit der 570er um die 600 sec = 4523 Credits :thumbup:

Gruss phaeton57:x)

SoEinWahnsinn
04.05.2011, 16:23
@ gu wo


cudaSafeCall() Runtime API error in file <c:/Source/Collatz/CollatzCudaKernel3.cu>, line 513 : unknown error.

Ich hab zwar keine Nvidia aber bei dem Fehler würde ich erst mal alle Collatz WUs abbrechen das Projekt abmelden die Collatz Ordner per Hand löschen. Dann wie gehabt wieder anmelden. An Primegrid wird es wohl nicht liegen...

gu_wo
04.05.2011, 20:57
@ gu wo


cudaSafeCall() Runtime API error in file <c:/Source/Collatz/CollatzCudaKernel3.cu>, line 513 : unknown error.

Ich hab zwar keine Nvidia aber bei dem Fehler würde ich erst mal alle Collatz WUs abbrechen das Projekt abmelden die Collatz Ordner per Hand löschen. Dann wie gehabt wieder anmelden. An Primegrid wird es wohl nicht liegen...


Hallo,
jepp, hatte ja bereits alle Collatz WUs zu ende rechnen lassen, werde das gleich mal testen.

Melde mich dann wieder ;)


Hinzugefügter Post:

Hi,

so, habe Collatz abgemeldet, weder in ProgramData/Boinc, ProgramData/Boinc/projects noch in Program Files/Boinc war irgendetwas zu finden was ich hätte löschen können. :undecided:

egal .... PC neu gestartet, Collatz wieder angemeldet, kann aber noch etwas dauern bis es an der Reihe ist, bin mal gespannt :D

THX


Hinzugefügter Post:

Hi,
hatte mal PG angehalten, so das Collatz weiterrechnen kann, ich erhalte z.Z. nur mini collatz v2.05 (cuda31) und alle enden nach ca. 4 min. mit Berechnungsfehlern, das gute daran, die werden auch immer brav abgeholt. :sad:

Das kann es doch nicht sein.:rolleyes:

Habe jetzt mal in den Collatz Ordner geschaut, so siehts da aus, mal ne laienhafte Frage, darin befindet sich "mini_collatz_2.05_windows_x86_64__cuda31.exe" wenn ich die einfach daraus lösche, würde das was bringen, so das ich KEINE mini collatz mehr bekommen?

http://img7.imageshack.us/img7/2241/minicollatz01.jpg (http://img7.imageshack.us/i/minicollatz01.jpg/)


Hinzugefügter Post:

Frage schon selbst beantwortet, BRINGT NIX, die .exe ist nach dem Start von Boinc wieder da.

pschoefer
04.05.2011, 21:16
Du kannst die mini_collatz in den Projekteinstellungen (http://boinc.thesonntags.com/collatz/prefs.php?subset=project) abwählen.

gu_wo
07.05.2011, 10:41
;189623']Du kannst die mini_collatz in den Projekteinstellungen (http://boinc.thesonntags.com/collatz/prefs.php?subset=project) abwählen.

Jaaa super! 1000 Dank, jetzt müßte wieder alles einwandfrei laufen!:thumbup:


Hinzugefügter Post:

Hallo Männers,

erstmal vielen Dank für die super Hilfe, funktioniert mittlerweile alles einwandfrei. :thumbup:

Primegrid rennt wie der Teufel, wenn ich ihn lasse ;)
und bei meinem geliebten Collatz Conjecture läuft es auch wieder rund, seitdem mini collatz deaktiviert ist. ;)

Alle anderen Projekte lasse ich, wie schon zuvor, hin und wieder mal ran.


THX


Hinzugefügter Post:

Hallo,

habe leider doch noch ein Problemchen und zwar. :sad:
Sobald ich den Bionc Manager aus mache und und z.B. surfen möchte, friert mein Firefox Browser (4.0.1) für ca. 10 sec. ein, danach kommt folgende Meldung.

http://img192.imageshack.us/img192/7754/anzeigetreiberfehler.jpg (http://imageshack.us/photo/my-images/192/anzeigetreiberfehler.jpg/)

also das ist NUR wenn ich den Boinc aus mache, sonnst läuft alles prima.

Die neusten Treiber für graka und Monitor sind auch installiert.

THX


Hinzugefügter Post:

Hallo,

ich vermute es lag am graka Treiber, hatte gegooglet, das Problem war bekannt. Treiber deinstalliert und auch manuell alles gelöscht, neusten Treiber wieder drauf, fertig.

Nun ja, bis jetzt ist zumindest das Problem auch nach mehreren Tests nicht mehr aufgetreten.

Gruß, hd-man :D

gu_wo
08.05.2011, 22:56
hat nix gebracht, der Fehler taucht immer noch auf. :undecided:

Piti
06.03.2012, 16:30
Guten Tag

Rechnet schon jemand Collatz mit einer AMD HD 7970 und kann mir ca. sagen was die an credits macht?
Wird die überhaupt schon richtig unterstützt?
Vielen Dank!

Gruß
Piti

Yeti45
06.03.2012, 18:59
Habs mit ner 7950 probiert, komme damit aber auf keinen grünen Zweig. :undecided:
Bei der normalen Anwendung sind die meisten WUs nur Ausschuss, und die optimierte Anwendung für OpenCL (die man eigentlich nehmen sollte) produziert hier nur Abbrüche.
Leider weiss ich die Ursache nicht und wollte erst mal ein wenig zuwarten. Milkyway läuft schliesslich ganz gut (ohne Boinc 7.x beta installieren zu müssen) :)

Nachtrag:
So.. mittlerweilen läuft es bei mir auch mit Collatz. Ich verwende die 3.08 aus dem dortigen Forum (http://boinc.thesonntags.com/collatz/forum_thread.php?id=843&nowrap=true#13645).
Diese braucht hier etwa 28 Minuten und ich erhalte dafür ca. 3000 Cr.
Bei Milkyway ist die Ausbeute fast doppelt so hoch (ca. 10000/h).

Blacky
06.05.2012, 18:33
Die Colllatz-WUs (mini_collatz) für die GPU produzieren bei mir überwiegend Fehler.
Von ca. 60 WUs haben 50 WUs gleich nach 1s einen Berechnungsfehler gehabt.
Ich werde jetzt mal collatz-WUs für die GraKa laufen lassen.
Kann das evtl. am neuen Treiber liegen? Habe seit heute einen neuen Treiber installiert --> 295.73 für meine NVIDEA GTX 460M.
Bei DstrRTGen hat es danach auch jede Menge Fehler gegeben.

MfG
Blacky
:x):x):x)

Coca-Cola
06.05.2012, 19:05
Die Colllatz-WUs (mini_collatz) für die GPU produzieren bei mir überwiegend Fehler.
Von ca. 60 WUs haben 50 WUs gleich nach 1s einen Berechnungsfehler gehabt.
Ich werde jetzt mal collatz-WUs für die GraKa laufen lassen.
Kann das evtl. am neuen Treiber liegen? Habe seit heute einen neuen Treiber installiert --> 295.73 für meine NVIDEA GTX 460M.
Bei DstrRTGen hat es danach auch jede Menge Fehler gegeben.

MfG
Blacky
:x):x):x)

Moin,

bei meiner GT 520 ist es fast das gleiche, nur das der Rechner dazu ständig zum Neustart veranlasst wird.:(

Ich hab bei diesem Rechner mit Collatz aufgegeben.:undecided:

Drink
Coca-Cola

Uwe-Bergstedt
06.05.2012, 19:08
hab ihr mal die Monitorabschaltung von Windows abgestellt??--bzw auf: DAUER gestellt??

den Monotor mit dem Ausschalter am Monitor ausstellen!!!!!!!!!!!!

Coca-Cola
06.05.2012, 19:14
hab ihr mal die Monitorabschaltung von Windows abgestellt??--bzw auf: DAUER gestellt??

den Monotor mit dem Ausschalter am Monitor ausstellen!!!!!!!!!!!!

Ok, widererwarten stand die Einstellung tatsächlich auf 15 min.:confused:

Jetzt probier ich´s nochmal.

Drink
Coca-Cola

Blacky
06.05.2012, 19:28
Mit den normalen collatz_WUs habe ich das gleiche Problem. Die erste ist jetzt nach 54min mit Berechnungsfehler abgebrochen. :sad:
Zur Monitorabschaltung: Nach 5 Minuten wird der Monitor abgeschaltet. Damit hatte ich früher aber überhaupt keine Probleme.

MfG
Blacky
:x):x):x)

taurec
06.05.2012, 19:32
Mit den Treiberversionen 280.26 bzw. 285.62 sollte es diese Probleme nicht geben. Stand hier irgendwo mal in einem anderen Thread. Meine 8800GTS läuft mit dem 280er.

[SG] Harald_(Charly)
06.05.2012, 19:43
550er Ti unter 32-Bit Vista mit 301.24 -> keine Probleme
250er GTS unter 64-Bit W(ürg)7 mit 301.24 -> keine Probleme
8600er GS unter 64-Bit W(ürg)7 mit 296.10 -> keine Probleme

Bei allen ist die automatische Abschaltung deaktiviert

EDIT:

Hier der Link zu meinen Gurken -> http://boinc.thesonntags.com/collatz/hosts_user.php?userid=629


Hinzugefügter Post:

Die Minis lass ich nur auf der 86er laufen.. bei den normalen rödelt die sich nen Wolf..
Die beiden anderen GraKas crunchen was kommt..

Blacky
06.05.2012, 19:53
Ich glaube nicht, dass ich das auf meine GraKa übertragen kann.
Bei mir rechnet eine GTX 460M (Notebook).
Ich werde mal den alten Treiber installieren und die Sache weiter beobachten.

MfG
Blacky
:x):x):x)

Rainer Baumeister
06.05.2012, 20:37
Warum müssen auch immer die neuesten Treiber genutzt werden. Läuft wegen Pentathlon bei mir auch auf den NV 560ti und das mit 280.26 ohne Probs.
Sausen in 35 Min. durch. Gruß Rainer

Blacky
06.05.2012, 20:55
Da mein alter Treiber auf der Herstellerseite des Notebooks nicht mehr angeboten wird, musste ich jetzt den Treiber von der mitgelieferten CD installieren. Version 259.12 --> richtig alt!!!
Die neuere Version 285.62 macht beim Installieren Schwierigkeiten und die neueste Version 295.73 hat die Probleme mit der Monitorabschaltung. Davon hatte ich schon gehört, hat mich aber zum Glück noch nie erwischt. Bis auf heute.
Mein Treiber, den ich bis heute Morgen hatte, lag irgendwo zwischen 280.00 und 285.62. Den damaligen Treiberdownload habe ich nicht gespeichert. Warum nur.... sonst speichere ich auch jeden Mist!!!
Leider kann ich auch die Treiber auf der NVIDEA-Seit nicht installieren, da gibt es auch irgendwelche Schwierigkeiten.
Warum muss auch jeder Notebookhersteller auf seine eigenen Treiber bestehen?????

MfG
Blacky
:x):x):x)

Acid303
06.05.2012, 22:35
Schau mal auf http://www.laptopvideo2go.com/ da gibts original nvidia Treiber mit passendem inf mod zum installjeren auf Laptops.

Gesendet von meinem Galaxy Nexus mit Tapatalk 2