PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Collatz auf einer Nvidia 660 ti



wadnatze
27.04.2014, 07:28
Hallo zusammen und einen schönen Sonntag!

Es gibt ja jetzt Mini, Solo, Large und Micro Colatz. Zur Large-Version mal eine Frage, sie läuft mit einer GPU-Auslastung von 51%, ist das nicht etwas wenig?

Oder gibt es schon optimierte Anwendungen (app_config oder ähnliches) die im Umlauf sind?

Solo Colatz liefen heute Nacht mit einer Laufzeit von 23 min mit einem freigehaltenem CPU-Kern, was ist da die Meinung, ok oder nicht?

Andere habe ich noch nicht bekommen.

Gruß, wadnatze

Handicap SG-FC
27.04.2014, 08:06
Moin wadnatze,

ich rechne die langen nicht da ich nicht weiß wie lange die brauchen. Die Anzeige im BT zeigen Zeiten an die hinter dem Abgabe Datum liegen.

Ich rechne mit 0.33C + 0.5NV 2 gleichzeitig und liege bei 25 - 50 Min.

Alles für CUDA 55

Karte ist nicht übertaktet.

Hoffe es hilft Dir weiter

Grüße

Handi

Buckey01
27.04.2014, 08:07
Hi wadnatze,

ich habe bei mir nur solo´s als Cuda auf den 660 ti laufen.
Die Laufzeit scheint ok. Unter Windows laufen meine WU´s mit cuda55 ~18 min, unter Linux (64 bit) mit cuda40 ~28 min.
CPU-Kerne habe ich nicht freigehalten, da kein ocl bei mir läuft.

Ich habe mal ne Zeitlang die OCL-Anwendung ausprobiert und musste feststellen, dass die bei mir langsamer läuft.

Gruß Micha

pons66
27.04.2014, 08:20
Die Large Collatz lief mit der 660 Ti etwa 25 Stunden. Die geschätzte Zeit war mit über 4000 Stunden angegeben.

In der Datei "large_collatz_windows_x86_64_cuda.config" habe ich Folgendes eingetragen:

verbose=1
items_per_kernel=21
kernels_per_reduction=9
threads=8
sleep=1
Da die Berechnung in der Nacht (gegen 1:00 Uhr) abgeschlossen war, habe ich keine Infos zu den Credits. Die Tasks werden bei Collatz unglaublich schnell aktualisiert. Ältester Eintrag ist vom 27.04.2014, 3:15 Uhr.

Die Solos laufen zwischen 270 und 1100 Sekunden, überwiegend jedoch um die 550 Sekunden.

wadnatze
27.04.2014, 09:38
@pons66:

Hab mal die Einstellung übernommen, mal sehen was wird.

Bei mir waren auch > 100 Tage bei den "Large"angezeigt, jetzt sind ca. 6 h um und der Fortschritt ist bei 25 %.

Stargazer
27.04.2014, 14:25
Ich bin bei meiner nvidia 460SE momentan nach 26h bei knapp 50%. Gestartet hatte der Spass bei 1900Tagen (jetzt angegeben: noch 222h Restlaufzeit).

Na mal sehen, was da noch so kommt, um die restliche Zeit vollzubekommen. ^^

pons66
27.04.2014, 15:13
Die jetzigen Wutzen von Large Collatz werden mit 13 Stunden angekündigt. Mit der 660 Ti sind wohl etwas weniger als 10 Stunden (12 Prozent bei 1:10 Stunden) erforderlich.
Mit der 680-er habe ich diese Anwendungen bisher noch nicht gerechnet. Nach 2 Solos gehts dann los.

Uwe-Bergstedt
27.04.2014, 17:07
bei mir mit einer 660Ti zur Zeit bei 79% nach 20Std

die Radeon R9 290X brauchte nur 10 3/4 Std und es gab

Sekunden= 38,578.26 ; CPU-Zeit=30.62 ; Punkte=253,339.78 Large Collatz Conjecture v6.04

Freezing
28.04.2014, 07:13
weiß einer von euch wie ich z.B. die large collaz auf bestimmte maschinen blockieren kann ohne gleich die config vom collaz über die homepage zu ändern?

ich habe leider eine maschine die sich die large collaz zieht und mit der integrierten intel GPU es nicht innerhalb der deadline schafft diese abzuarbeiten...

die anderen maschinen, die bei collaz mitmachen, schaffen die großen WU´s und deswegen will ich bei den einstellungen im projekt selbst nichts ändern...

geht das irgendwie über eine app_config oder cc_config?

Meiner Einer
28.04.2014, 07:42
weiß einer von euch wie ich z.B. die large collaz auf bestimmte maschinen blockieren kann ohne gleich die config vom collaz über die homepage zu ändern?

ich habe leider eine maschine die sich die large collaz zieht und mit der integrierten intel GPU es nicht innerhalb der deadline schafft diese abzuarbeiten...

die anderen maschinen, die bei collaz mitmachen, schaffen die großen WU´s und deswegen will ich bei den einstellungen im projekt selbst nichts ändern...

geht das irgendwie über eine app_config oder cc_config?
Gib den Maschinen die die Large nicht bekommen sollen ein anderes Standort Profil, (Separate Einstellungen für home,
für school oder
für work hinzufügen)
auf der Kontoseite.
Dann da Large ab wählen.

Handicap SG-FC
28.04.2014, 12:50
Wie pons66 ja oben schon sagte gibt es ja auch die Einstell Möglichkeiten.

" large_collatz_windows_x86_64_cuda.config "

Nun benutze ich hier selber aber immer noch die app_config.xml, die anderen Configs habe ich alle leer.

Verschenke ich damit nun was ??

Thx & Grüße

Handi

HJL
28.04.2014, 12:56
;258644']Wie pons66 ja oben schon sagte gibt es ja auch die Einstell Möglichkeiten.

" large_collatz_windows_x86_64_cuda.config "

Nun benutze ich hier selber aber immer noch die app_config.xml, die anderen Configs habe ich alle leer.

Verschenke ich damit nun was ??

Thx & Grüße

Handi

jep, je nach GraKa sogar ganz gewaltig ;)
mit den Einstellungen (weiter oben von Pons) laufen die bei mir etwa 40% schneller
ich hab items_per_kernel sogar auf 22 stehen ...
etwas auf die Temperaturen achten ...

:x) hl

edit: ich rechne allerdings die Solo-Collatz, das sollte aber keinen Unterschied machen ...

nochmal edit: >hier< (http://boinc.thesonntags.com/collatz/download/opt_config/) gibt's für verschiedene GraKas schon diverse fertige configs ... ;)

Handicap SG-FC
28.04.2014, 13:29
Hi HJL,

Dein Link zeigt aber doch auf configs für Opencl ??

Das verwirrt mich gerade etwas...

Und kann ich den beides einsetzen ?? Also die Configs für die einzelen WU's und die app_config ?? oder überschneidet sich das dann ??

Thx

Handi

shka
28.04.2014, 14:13
Ob OpencL oder Cuda - dass müssten andere sagen. Ich rechne auf der 660ti cuda55, die schienen mir etwas schneller.

Und die kannst du noch beschleunigen um mehr als 40%, wenn du jeweils in die configs folgende Werte einträgst (man kann die sicherlich noch GPU-abhängig variieren)

verbose=1
items_per_kernel=21
kernels_per_reduction=9
threads=8
sleep=1

Bei mir (Win64, Cuda55) sind das im Verzeichnis C:\ProgramData\BOINC\projects\boinc.thesonntags.co m_collatz die mini_collatz_windows_x86_64_cuda.config, solo_collatz_windows_x86_64_cuda.config, large_collatz_windows_x86_64_cuda.config. Die angefangene wird noch mit der alten Einstellung fertiggerechnet, die neue (Neustart des BM notwendig?) dann mit der neuen. Man kann erkennen, ob die neuen EInstellungen verwendet werden, unter den Infos zur WU hier ein Beispiel (http://boinc.thesonntags.com/collatz/result.php?resultid=5999083), dort ab Zeile 6 in der Stderr Ausgabe noch einmal aufgeführt.

Effekt bei mir (vergleichbare Solo-Cuda-WUs auf Grund Creditvergabe)
vorher - Laufzeit > 8 Minuten, Auslastung ca. 92% mit Schwankungen zwischen 75-95%
nachher - Laufzeit <5 Minuten, Auslastung 99%, ganz ganz geringe Schwankungen, Temps 2 Grad höher, System gefühlt etwas träger

Handicap SG-FC
28.04.2014, 14:41
Hi shka,

das habe ich soweit auch verstanden, ich rechne auch nur die Cuda55.

Allerdings immer 2 gleichzeitig und wenn ich mir die Zeiten von Euch so ansehe komme ich ins staunen.

Na dann werde ich das doch mal antesten. Mehr als ungültig kann er ja nicht machen.

Thx

wadnatze
28.04.2014, 19:14
Vielen Dank für die vielen Informationen und Eure Hilfe.
Einige habe ich schon umgesetzt.
Momentan rechne ich zwei Mini_Collatz parallel, dafür habe ich einen Kern freigehalten.
Einstellung:
verbose=1
items_per_kernel=21
kernels_per_reduction=9
threads=8
sleep=1

Laufzeit pro WU (bei zwei parallel) zwischen 5,5 min und 6,5 min.

Gruß, wadnatze

P.S.: Handicap, danke für die PN.

pons66
28.04.2014, 20:21
Mit der 660 Ti hatte die letzte Large Collatz 33800 Sekunden gedauert, Credits = 226000,
mit der 680-er waren es 30100 Sekunden, Credits = 235000.

Die Mini Collatz liefen mit der 660 Ti zwischen 3,8 und 4,6 Minuten.

wadnatze
29.04.2014, 18:23
Kann mir jemand erklären warum mir bei WUprop keine Rechenzeit für die Mini-Collatz gutgeschrieben wird? Ein zurücksetzen von WUprop hat nichts gebracht. :confused-new:

Momentan rechne ich eine WU Mini-Collatz, Dauer pro WU zwischen 2 min 45 sec und 2 min 55 sec.

Das Thema mit zwei WU's parallel habe ich aufgegeben, da eine WU dann > 6 min gedauert hat.

Gruß, wadnatze

shka
29.04.2014, 18:38
Kann mir jemand erklären warum mir bei WUprop keine Rechenzeit für die Mini-Collatz gutgeschrieben wird? Ein zurücksetzen von WUprop hat nichts gebracht. :confused-new:

Vorher stand hier Blödsinn meinerseits

Habe gerade nachgeschaut, bei mir werden in der Acticvity-Auswertung des Rechners auch nur Solo und Large bei Wuprop aufgeführt. :shocked:

Stargazer
29.04.2014, 18:54
Mal noch zum Vergleichen; meine 460SE brauchte 210224sek (4590cpu-sek) ohne weitere spezielle Optimierungen. :)

Ihr könnt ja gern mal noch Vergleichswerte Eurer Karten zu den einzelnen Anwendungen (http://www.seti-germany.de/wiki/Collatz_Conjecture#Anwendungen)angeben. Gern auch von AMD/ATI ;)

HeNiNnG
29.04.2014, 19:15
Kann mir jemand erklären warum mir bei WUprop keine Rechenzeit für die Mini-Collatz gutgeschrieben wird? Ein zurücksetzen von WUprop hat nichts gebracht. :confused-new:


Sprich das mal im Unterforum von WUprop an wird dann sicher gen Frankreich weitergeleitet....;)

Juergen125
01.11.2014, 21:41
Hallo,

möchte gerne eine weitere Graka zur Verfügung stellen.
Es handelt sich dabei um eine GTX 770.
Kann mir bitte jemand helfen diese zu optimieren!
:x)
Juergen125

Rainer Baumeister
02.11.2014, 04:38
Moin Jürgen, da braucht nichts optimiert werden.
Einzig das Unterprojekt Solo Collatz auswählen und Boinc starten.
Mit Nvidia braucht es auch keinen Kern, im Gegensatz zu ATI-Karten.
Gruß Rainer

Dr. Frank-N-Furter
02.11.2014, 08:23
Moin Jürgen, da braucht nichts optimiert werden.
Einzig das Unterprojekt Solo Collatz auswählen und Boinc starten.

das wäre mir neu.

alles wichtige findet sich aber hier in diesem thread schon.

Juergen125
02.11.2014, 15:02
Moin Rainer,

vielen Dank! Ist nicht so mein Projekt aber es wurde diskutiert das man dort momentan zusätzliche Grafikkarten braucht.
:x)
Juergen125

Freezing
07.07.2015, 19:59
Hi,
seit dem update der CUDA Version auf 6.06 funktioniert CC wieder bei mir und bricht nicht gleich jede WU zu beginn ab aber die laufzeit ist nun zwei bis drei mal länger...
natürlich habe ich die config erneut angepasst:

verbose=1
threads=8
items_per_kernel=21
kernels_per_reduction=8
sleep=1

kann das jemand bestätigen?

Sysadm@Nbg
07.07.2015, 20:08
mit update meintest du diese zugehörige Meldung?

New Windows CUDA and OpenCL Versions Released
CUDA version 6.06 and OpenCL version 6.08 were released for Windows today. The CUDA version fixes (I hope) a "device not ready" bug ...
klick (http://boinc.thesonntags.com/collatz/forum_thread.php?id=1284)

Freezing
07.07.2015, 20:33
Sag ich doch ;)
CUDA 6.06

Mittlerweile hat sich CC per Forum gemeldet:

The default lookup table size is now 12 (down from 20) which makes some GPUs run faster and others run slower. It appears that your 660ti has an L2 cache size of 384K. Using a lut_size of 15 which uses 8(2^15) bytes or 256K is likely the optimal setting for your GPU. You may also want to try values of 14, 16, and 20 for comparison.

verbose=1
threads=9
items_per_kernel=21
kernels_per_reduction=8
sleep=1
lut_size=15

Ich habe dann diese config aber mit der lut_size=20 genommen...läuft nun viel schneller, aber immer noch nicht so toll wie damals...

ich hatte mit den 660 ti´s ca. 2500 sec für eine solo WU...nach dem Update der 6.06 waren es 6000...mit meiner ursprünglichen config dann 5000 und nun mit der hier gezeigten config ca 2900 sec...
__________________