Ergebnis 1 bis 11 von 11

  1. Titel
    Neuling

    Bewertung

    Registriert am
    12.12.2014

    Beiträge
    6

    Danke
    Danke gesagt 0   Danke erhalten 0

    #1

    Standard GPU(s) werden unter Ubuntu 14.04 LTS mit Boinc und KDE nicht erkannt.

    Lösung zu :

    GPU(s) werden unter Ubuntu 14.04 LTS mit Boinc und KDE nicht erkannt.

    Problem:

    Ubuntu 14.04 LTS mit KDE und Boinc ist installiert incl. der Treiber von nVidia aus den Paketquellen.
    Momentan 331.xx
    Trotzdem wird die GPU nicht erkannt.

    Lösung:

    Als erstes werden die Repos von nVidia hinzu gefügt. Dies passiert mit "sudo dpkg -i cuda-repo-ubuntu1404_6.5-14_amd64.deb"
    Das Debian Paket installieren.
    Anschließend ein "sudo apt-get update" machen.

    Nun wurden neue Pakete gefunden. Unter KDE am einfachsten per Muon installieren.

    Nun wird der Boinc Client gestoppt. Dies mit "sudo service boinc-client stop"

    Anschließend mit "sudo apt-get install cuda" die Cudapakete incl. Treiber 340.29 installieren. Das dauert ne ganze Weile . Das Paket ist ca. 1GB groß.

    Nach der Installation der Cuda-Pakete und des Graka-Treibers, sollte automatisch ablaufen, ist ein reboot von Nöten.
    Anschließend sollte(n) die GPU(s) von Boinc gefunden werden.

    Gruß,
    Raskolnikow

    Wer Fehler in der Beschreibung findet möge diese anmerken.
    Geändert von Raskolnikow (16.01.2015 um 19:39 Uhr)

  2. Avatar von m4gu5
    Titel
    Freie Cruncher

    Bewertung

    Registriert am
    27.11.2014

    Beiträge
    185

    Danke
    Danke gesagt 4   Danke erhalten 6

    #2

    Standard

    Hallo Raskolnikow,

    wo bekommt man denn die deb-Datei "cuda-repo-ubuntu1404_6.5-14_amd64.deb" her?


  3. Titel
    Neuling

    Bewertung

    Registriert am
    12.12.2014

    Beiträge
    6

    Danke
    Danke gesagt 0   Danke erhalten 0

    #3

    Standard

    Hallo m4gu5,

    berechtigte Frage.

    http://developer.download.nvidia.com...5-14_amd64.deb

    Der Link führt gleich zum Download. Das Paket kann auch über das Ubuntu Software Center installiert werden. Dazu beim DL "öffnen mit Ubuntu Software Center" wählen.

    Danach gehts weiter wie oben beschrieben mit "sudo apt-get update"
    Der Rest ist gleich.

  4. Avatar von SETIBOOSTER
    Titel
    BOINC Maniac

    Bewertung

    Registriert am
    28.03.2008

    Ort
    Westerwald

    Beiträge
    930

    Danke
    Danke gesagt 42   Danke erhalten 87

    #4

    Standard

    Nicht alle CUDA Versionen funktionieren mit jeder Ubuntu Version.
    Die letzte bei mir mit CUDA funktionierende und die GPU unterstützende Version war Ubuntu 12.04 LTS.
    Folge Versionen funktionierten auf Grund einer C++ Bibliothek-Inkompatibilität des von CUDA benötigten nicht.
    Kann jedoch sein, das sich das geändert hat. Bin mir nicht sicher, da ich zu OS X gewechselt bin.
    Generell ist es nach meiner Erfahrung stabiler gewesen, CUDA selber zu installieren, da aptget nicht die passende CUDA Version auswählte.
    Bei Problemen fummele ich mich gerne kurz wieder rein und schreib Dir 'ne Anleitung hier.

  5. Avatar von Grubix
    Titel
    BOINC Maniac

    Bewertung

    Registriert am
    19.08.2008

    Ort
    Unna

    Beiträge
    883

    Danke
    Danke gesagt 46   Danke erhalten 58

    #5

    Standard

    Hallo Raskolnikow, schönen Dank für deine Beschreibung. Ich habe es noch nicht ausprobiert, weil ich nach diesem Thread irgendwann frustriert aufgegeben habe. Ich werde aber nächste Woche nochmal einen Versuch starten.

    Falls es nicht klappt, würde ich mich freuen wenn SETIBOOSTER oder du ein paar Tipps habt.

    Bis denn dann, Grubix.

  6. Avatar von SETIBOOSTER
    Titel
    BOINC Maniac

    Bewertung

    Registriert am
    28.03.2008

    Ort
    Westerwald

    Beiträge
    930

    Danke
    Danke gesagt 42   Danke erhalten 87

    #6

    Standard

    Kein Problem.

  7. Avatar von taurec
    Titel
    ist hier zu Hause

    Bewertung

    Registriert am
    30.06.2008

    Ort
    Allerorten

    Beiträge
    3.871

    Danke
    Danke gesagt 211   Danke erhalten 55

    #7

    Standard

    Hallo zusammen,
    mein Fx8120 wird derzeit mit der Debian-Distro Siduction, Kernel 3.18.3 64bit, nvidia-Treiber 346.35 betrieben.
    Für Debian, Antix u.a. gibt es da ein hilfreiches Skript um die Grafikkarten-Treiber zu installieren, hat bei mir jedenfalls bisher meistens geklappt. Schaut mal hier:
    http://smxi.org/site/about.htm
    Dort nach sgfxi suchen und mal lesen.
    Soll auch mit Ubuntu funktionieren:
    Zitat: Support for Ubuntu and Arch Linux has been added to sgfxi, so now it should work in most areas in Debian, Ubuntu, and Arch.


    Erfahrung mit der Installation von ATI/AMD-Treibern habe ich leider bisher nicht.
    Ciao taurec


  8. Titel
    Neuling

    Bewertung

    Registriert am
    12.12.2014

    Beiträge
    6

    Danke
    Danke gesagt 0   Danke erhalten 0

    #8

    Standard

    Zitat Zitat von SETIBOOSTER Beitrag anzeigen
    Nicht alle CUDA Versionen funktionieren mit jeder
    Generell ist es nach meiner Erfahrung stabiler gewesen, CUDA selber zu installieren, da aptget nicht die passende CUDA Version auswählte.
    Genau das hatte ich vorher probiert. Sah auch alles nett aus. Hat nur nicht funktioniert in dem Sinne das die GPUs erkannt wurden.

    Der eigentliche Knackpunkt an der Sache ( danke an Fox2k7 ) ist die Repos von nVidia ein zu binden.

  9. Avatar von m4gu5
    Titel
    Freie Cruncher

    Bewertung

    Registriert am
    27.11.2014

    Beiträge
    185

    Danke
    Danke gesagt 4   Danke erhalten 6

    #9

    Standard

    Ich hatte vor ein paar Wochen ja auch das Problem, dass nach einem Update bestimmter Packages (weiß leider nicht mehr welche genau) meine 560Ti nicht mehr erkannt wurde von BOINC.
    Hab dann auch alles mögliche ausprobiert und nutze jetzt die Packages nvidia-304 und nvidia-opencl-icd-304 aus dem xorg-edgers Repo. Seitdem funktioniert alles wieder einwandfrei.

  10. Avatar von SETIBOOSTER
    Titel
    BOINC Maniac

    Bewertung

    Registriert am
    28.03.2008

    Ort
    Westerwald

    Beiträge
    930

    Danke
    Danke gesagt 42   Danke erhalten 87

    #10

    Standard

    Zitat Zitat von Raskolnikow Beitrag anzeigen
    Der eigentliche Knackpunkt an der Sache ( danke an Fox2k7 ) ist die Repos von nVidia ein zu binden.
    ...was ich mit selbst installieren meinte...sorry zu lange gepinguint und deshalb Verstehen vorrausgesetzt...Asche auf mein Haupt


  11. Titel
    Neuling

    Bewertung

    Registriert am
    12.12.2014

    Beiträge
    6

    Danke
    Danke gesagt 0   Danke erhalten 0

    #11

    Standard

    Da ich die Tage aus versehen, mit einem anderen Benutzer, ( Standard ) nVidia Treiber aus den Paketquellen installierte, liefen die GraKas unter Boinc nicht mehr bzw. wurden erst gar nicht mehr erkannt da diese Aktion benutzerübergreifend war.

    Was nun tun ?

    Von manuellem Rumgeschraube, ausgenommen man weiß haargenau was man tut, kann ich nur abraten.

    Lösung:

    Da das Cuda Paket aus der nVidia Repo nun erstmal überflüssig ist lässt es sich einfach mit "sudo apt-get autoremove" entfernen.
    Anschließend ein Neustart. Danach prüfen ob die nVidia Repo weiterhin aktiv ist.

    Dann das Cuda-Paket mit "sudo apt-get install cuda" neu installieren.
    Noch ein Neustart.

    Nun sollte wieder alles sein wie vor dem "Unfall".

Ähnliche Themen

  1. Boinc Update unter LInux Ubuntu
    Von Christoph D. im Forum Software - Installation, Probleme usw.
    Antworten: 18
    Letzter Beitrag: 23.12.2012, 03:06
  2. Boinc auf Ubuntu läuft auf einmal nicht mehr
    Von Mister.X im Forum Software - Installation, Probleme usw.
    Antworten: 16
    Letzter Beitrag: 04.08.2012, 17:34
  3. Ubuntu 10.10 64bit: GPU wird nicht erkannt
    Von triage im Forum Software - Installation, Probleme usw.
    Antworten: 5
    Letzter Beitrag: 04.03.2011, 21:08
  4. Nur zwei Grafikkarten werden erkannt
    Von Caveman im Forum Software - Installation, Probleme usw.
    Antworten: 19
    Letzter Beitrag: 05.02.2011, 18:58
  5. dringend: boinc unter mac os x geht nicht
    Von bfot im Forum Software - Installation, Probleme usw.
    Antworten: 4
    Letzter Beitrag: 27.05.2009, 21:47

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Single Sign On provided by vBSSO