Ergebnis 1 bis 14 von 14
  1. Avatar von Arkturus
    Titel
    Junior Member

    Bewertung

    Registriert am
    03.08.2010

    Beiträge
    84

    Danke
    Danke gesagt 7   Danke erhalten 4

    #1

    Standard Einstein und SETI langsam auf Titan V

    Liebes Community,

    wenn meine Titan V nicht gerade sinnvolleres zu tun hat lasse ich sie gerne unter Xubuntu 18.04 bei Einstein oder SETI rechnen. Mir ist dabei jedoch aufgefallen, dass die Auslastung der GPU extrem niedrig (zumeist im niedrigen zweistelligen Bereich) ist und die Rechenzeiten sogar länger als auf anderen Rechnern mit sehr viel schwächeren Grafikkarten. An der Hardware liegt es definitiv nicht, der Treiber macht auch sonst unter Linux keinerlei Probleme, es scheint eher mit BOINC zu tun zu haben. Habt ihr eine Idee, woran das liegen könnte? Ferner taucht meine Grafikkarte unter

    Code:
    boinccmd --get_host_info
    nicht auf.

    Cheers,
    Arkturus

  2. Avatar von nexiagsi16v
    Titel
    Gold Member

    Bewertung

    Registriert am
    05.12.2014

    Beiträge
    2.070

    Danke
    Danke gesagt 22   Danke erhalten 0

    #2

    Standard

    Wegen Einstein, evtl. mal openCL checken? https://www.seti-germany.de/forum/th...-GPU-auf-Linux
    Seti sollte es ja auch per Cuda gehen.
    Wird deine GPU auch nicht bei Boinc in den Meldungen ganz oben gefunden?
    Ciao Norman

    Ryzen 5 3600 @4GHz, 3x RX 5700, 32GB DDR4//FX8370 @4GHz, 16GB DDR3 1600, RX 470 + R9 270X// Dauercruncher i3 8300, 8GB RAM // Läppi B940 @2GHz

  3. Avatar von Arkturus
    Titel
    Junior Member

    Bewertung

    Registriert am
    03.08.2010

    Beiträge
    84

    Danke
    Danke gesagt 7   Danke erhalten 4

    #3

    Standard

    Hey,

    die notwendigen OpenCL-Pakete sind installiert.

    In welchen Meldungen soll meine GPU angezeigt werden? BOINC rechnet ja auf dem Ding, allerdings ist die Auslastung unterirdisch.

    Cheers,
    Arkturus

  4. Avatar von nexiagsi16v
    Titel
    Gold Member

    Bewertung

    Registriert am
    05.12.2014

    Beiträge
    2.070

    Danke
    Danke gesagt 22   Danke erhalten 0

    #4

    Standard

    Oben im Boincmanger auf "Werkzeuge" gehen und dann auf "Meldungen" In den ersten 15 Zeilen wird die erkannte Hardware aufgeführt. Diese Zeilen mal hier ins Forum kopieren.

    Achso, nicht alle Kernen frei Rechnen lassen. Einstein reserviert sich selber einen Kern/Thread für seine GPU WU, Seti macht das nicht. Also da maximal 99% bei "nutze höchstens % Prozessoren" eingeben.
    Ciao Norman

    Ryzen 5 3600 @4GHz, 3x RX 5700, 32GB DDR4//FX8370 @4GHz, 16GB DDR3 1600, RX 470 + R9 270X// Dauercruncher i3 8300, 8GB RAM // Läppi B940 @2GHz

  5. Avatar von Arkturus
    Titel
    Junior Member

    Bewertung

    Registriert am
    03.08.2010

    Beiträge
    84

    Danke
    Danke gesagt 7   Danke erhalten 4

    #5

    Standard

    Der Output sieht folgendermaßen aus:

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	boinc.jpg 
Hits:	10 
Größe:	29,9 KB 
ID:	6641

    Die Karte scheint ja korrekt erkannt zu werden. Dem Projekt nur 98% CPU-Nutzung zuzuteilen hat schon einmal ein bisschen gebracht, die GPU wird nun stärker ausgenutzt, allerdings auch nur phasenweise. In nvidia-smi schwankt doe GPU-Util zwischen knapp unter 10% und bis zu knapp unter 100%, die hohe Last wird immer nur für ein paar Sekunden gehalten. Ist das eine projektspezifische Eigenheit bei Einstein@Home?

    Edit: An der CPU-Nutzung liegt es nicht. Mein Bürorechner (Ryzen 7 3700X, GTX 1660 Super) läuft auf den gleichen Einstellungen und cruncht deutlich mehr WUs pro Zeiteinheit als die Titan V
    Geändert von Arkturus (03.03.2020 um 09:36 Uhr)

  6. Avatar von nexiagsi16v
    Titel
    Gold Member

    Bewertung

    Registriert am
    05.12.2014

    Beiträge
    2.070

    Danke
    Danke gesagt 22   Danke erhalten 0

    #6

    Standard

    Hast du mal nur die GPU-Anwendungen laufen lassen? Mach das mal und dann nur die Einstein GPU WU rechnen lassen. Welche Anwendung rechnest du bei Einstein mit was für einer Laufzeit und was für eine Punktausbeute für die WU.

    Mich beschleicht aber das Gefühl, das die Titan + Linux, nicht die beste Kombination ist. Die Grafikkarte ist ja schon recht seltene. Ob diese mit allen Treiberversionen und Linuxversionen sauber funktioniert?

    Grundsätzlich von der Hardware, müßte die richtig was abliefern...
    Ciao Norman

    Ryzen 5 3600 @4GHz, 3x RX 5700, 32GB DDR4//FX8370 @4GHz, 16GB DDR3 1600, RX 470 + R9 270X// Dauercruncher i3 8300, 8GB RAM // Läppi B940 @2GHz

  7. Avatar von Arkturus
    Titel
    Junior Member

    Bewertung

    Registriert am
    03.08.2010

    Beiträge
    84

    Danke
    Danke gesagt 7   Danke erhalten 4

    #7

    Standard

    Auf der Maschine mit dem Ryzen 7 3700X und der GTX 1660 Super braucht eine Einstein-WU (Gravitational Wave Search O2 Multi-Directional GP, 288 GFLOPs) etwas über 17 Minuten auf der GPU. Ein vergleichbares Paket auf der anderen Kiste (i9-9960X und Titan V) mit ebenfalls 288 GFLOPs läuft hingegen etwas über eine Stunde Probehalber habe ich den Spaß einmal auch unter Windows getestet - gleiches Ergebnis. An den Treibern kann es nicht liegen, jenseits von BOINC liefert die Titan das, was sie liefern sollte und die propritären Linux-Treiber von Nvidia sind in Zeiten von Tensorflow recht ausgereift.

    Schade, dass es nicht ordentlich läuft.

  8. Avatar von No_Name
    Titel
    ist hier zu Hause

    Bewertung

    Registriert am
    27.01.2017

    Ort
    Emsland

    Beiträge
    2.780

    Danke
    Danke gesagt 63   Danke erhalten 38

    #8

    Standard

    Hast du testweise einmal ein anderes GPU Projekt getestet, wie z.B. Primegrid oder Moo!Wrapper um die Projektanwendung auszuschließen?
    MfG No_Name alias trebotuet
    Zitat Zitat von shka Beitrag anzeigen
    PS: Ich gehe davon aus, dass du uns keine der Lösung dienlichen Hinweise aus dem Meldungs-Log verschweigst, nur um den Schwierigkeitsgrad der Lösungsfindung künstlich zu erhöhen.
    Der Rechenknecht . . . . . . . . . Stats . . . . . . . . . Badges


  9. Titel
    Full Member

    Bewertung

    Registriert am
    13.03.2014

    Ort
    Siegen

    Beiträge
    102

    Danke
    Danke gesagt 0   Danke erhalten 0

    #9

    Standard

    Doch, das läuft IMHO ordentlich.

    Die neue Anwendung O2MDF läuft nur zu einem Teil auf der GPU und benötigt für den anderen Berechnungsteil immer noch die CPU. Die GPU hat dann Pause und zeigt das von dir beobachtete Verhalten. Entsprechende Hinweise findest du in den länglichen Threads "Gravitational Wave search O2 Multi-Directional ("O2MD1")" und "Discussion Thread for the Continuous GW Search known as O2MD1 (now O2MDF - GPUs only)", die du sicher schon kennst.

    Einen höheren Durchsatz kannst du mit der gleichzeitigen Ausführung von mehr als einer WU erreichen. Ich benutze hier eine AMD Radeon VII und kann mit den zur Zeit verfügbaren "V2" WUs unter Linux bis zu vier oder fünf parallel laufen lassen, da die Laufzeiten sich nicht entsprechend vervielfachen. Unter Windows nur zwei, das mag an dem (lausigen) AMD-Treiber liegen.

    Ich würde in den Kontoeinstellungen den Faktor für die "GPU-Auslastung für GW-Applikationen" schrittweise von eins auf 0.5, 0.33, 0.25 bis auf 0.19 (für fünf WUs) reduzieren und Laufzeiten sowie Auslastung der GPU notieren.

    Wobei die Laufzeiten der O2MDF WUs im Gegensatz zu denen der Gamma-Ray Anwendung nicht konstant sind und durchaus um rund 30-50 % schwanken können. Das macht die Optimierung nicht einfacher.

    Viel Spaß beim Ausprobieren mit deiner schönen Titan V.

  10. Avatar von Arkturus
    Titel
    Junior Member

    Bewertung

    Registriert am
    03.08.2010

    Beiträge
    84

    Danke
    Danke gesagt 7   Danke erhalten 4

    #10

    Standard

    Besten Dank für die Aufklärung! Was mich jedoch etwas wundert: Auf der anderen Kiste (Ryzen 7 3700X, GTX 1660 Super) sehe ich besagtes Verhalten nicht. Hat das einen Grund? Handelt es sich vielleicht doch um etwas andere Arbeitspakete?

    Als nächstes würde ich gerne eine Erhöhung der Zahl der GPU-WUs angehen. Leide rkann ich die von dir genannte Einstellung "GPU-Auslastung für GW-Applikationen" in den Account-Einstellung von Einstein@Home nicht finden.


  11. Titel
    Full Member

    Bewertung

    Registriert am
    13.03.2014

    Ort
    Siegen

    Beiträge
    102

    Danke
    Danke gesagt 0   Danke erhalten 0

    #11

    Standard

    1. Bei Einstein anmelden und im Dashboard:

    Preferences > Project > Sonstige Einstellungen (unten).

    Wert ändern und Einstellungen speichern (ganz unten). Die neuen Einstellunge werden erst nach neu heruntergeladenen WU aktiv, vorher nicht.

    2. Deine 1660 Super ist vermutlich schon mit einer Instanz der O2-Anwendung gut ausgelastet, zumindest ist das bei meiner 1050Ti der Fall. Die Titan hat mehr PS unter der Haube, deswegen langweilt sich die Karte mit nur einer WU.

    3. Die o. g. Threads findest du im Forum von Einstein, nicht hier.

  12. Avatar von Arkturus
    Titel
    Junior Member

    Bewertung

    Registriert am
    03.08.2010

    Beiträge
    84

    Danke
    Danke gesagt 7   Danke erhalten 4

    #12

    Standard

    Huch, ich hätte einfach im Reiter "Project" schauen müssen ... Computing ergab irgendwie mehr Sinn Vielen Dank für deine Hilfe! Wenn ich das richtig verstehe, wird die Änderung nun jedoch alle Hosts betreffen? Die 1660 Super soll nämlich weiterhin nur eine WU zur Zeit rechnen ...

  13. Avatar von No_Name
    Titel
    ist hier zu Hause

    Bewertung

    Registriert am
    27.01.2017

    Ort
    Emsland

    Beiträge
    2.780

    Danke
    Danke gesagt 63   Danke erhalten 38

    #13

    Standard

    Du kannst verschiedene Profile einrichten und dann die jeweiligen Rechner einem zuweisen
    MfG No_Name alias trebotuet
    Zitat Zitat von shka Beitrag anzeigen
    PS: Ich gehe davon aus, dass du uns keine der Lösung dienlichen Hinweise aus dem Meldungs-Log verschweigst, nur um den Schwierigkeitsgrad der Lösungsfindung künstlich zu erhöhen.
    Der Rechenknecht . . . . . . . . . Stats . . . . . . . . . Badges


  14. Titel
    Full Member

    Bewertung

    Registriert am
    13.03.2014

    Ort
    Siegen

    Beiträge
    102

    Danke
    Danke gesagt 0   Danke erhalten 0

    #14

    Standard

    Preferences > Project > Preference set

    Dort definiert man bis zu vier unterschiedliche Voreinstellungen für das Projekt. Default ist "Generic".

    Ich habe z. B. "Home" für meinen i3570k/Windows und "Work", wenn der gleiche Rechner mit Linux läuft.

    Die Zuordnung Computer -> Preference wird im Dashboard vorgenommen: Computer wählen/anklicken -> dann ganz unten in "Ort" den gewünschten Wert einstellen.

    Danach in Boinc im Projektreiter einmal "aktualisieren".

    Alles etwas verwirrend, aber einfach mal ausprobieren. Versuch macht klug...

Ähnliche Themen

  1. SETI@home v7 auf GTX Titan
    Von Beorn im Forum SETI@home
    Antworten: 4
    Letzter Beitrag: 16.08.2013, 21:01
  2. Einstein rechnet immer vor Seti
    Von gormadoc im Forum SETI@home
    Antworten: 5
    Letzter Beitrag: 02.02.2013, 10:16
  3. Credits SETI vs. Einstein
    Von beggo im Forum SETI@home
    Antworten: 1
    Letzter Beitrag: 08.11.2009, 12:39
  4. Keine SETI-WU's wenn Einstein läuft
    Von marcseid im Forum BOINC
    Antworten: 5
    Letzter Beitrag: 03.12.2008, 21:05
  5. so langsam
    Von joe im Forum Hardware - Probleme, Tuning, Benchmark usw.
    Antworten: 11
    Letzter Beitrag: 08.11.2007, 21:11

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Single Sign On provided by vBSSO